Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 26, 2025 - 22:00 GMT
Scheduled
This release provides the ScreenApp with the capability to report more granularly on their different health statuses so that these can be shown on the Service Performance Dashboard.
Aim of the Screen Health Status is to provide GTS and Blackbox with quicker diagnostics when a screen fails, and therefore quicker resolutions of issues. It will also for better metrics on screen performance, both in a live view and on a period-by-period basis.
Reason or Justification for Change
In period reviews and contract mobilisation better tools to provide insight in the screen performance have been discussed and the Service Performance Dashboard, which includes the screen health data, was agreed as way to implement this.
Impact and Risk Analysis
The release will be implemented in 3 steps to reduce risks and impact for customers. After every step, a decision can be made to continue to the next release the next day. It is also possible after every step, to roll back the release within minutes. It would require a screen reboot.
26th November after 22:00: Edge ScreenApp will be released to the Ealing Broadway mainboard and all multimodal screens. As part of the release the screens will be rebooted, which in this case is expected to take up to a minute. To reduce customer impact the reboot will be done around 10pm. By releasing the new ScreenApp version to a subset of screens, the impact of the release is reduced to low.
27th November after 22:00: The remaining screens will receive the new ScreenApp to allow close monitoring and checking of the Service Performance Dashboard functionality in an extended live environment. As part of the release the screens will be rebooted, which in this case is expected to take up to a minute. To reduce customer impact the reboot will be done around 10pm. By releasing the new ScreenApp version in two steps, the impact of the release is reduced to low.
Posted Nov 21, 2025 - 17:21 GMT
This scheduled maintenance affected: DCIS Modules (Screens).