Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 02, 2025 - 22:00 BST
Scheduled
Full Details of the Required Change
This change is a reconfiguration in our underlying infrastructure.
Reason or Justification for Change
Continuous improvement
Impact and Risk Analysis
The impact of this change is a possible risk for a 2 minutes outage. The change is low risk. Should a roll back be required, there could be another 2 minutes outage.
Posted Sep 25, 2025 - 17:53 BST
This scheduled maintenance affected: DCIS Modules (Control Tower).