Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 26, 2025 - 12:00 GMT
Scheduled
Full Details of the Required Change
This change consists of two parts and aims to improve system security. The first part will be done around lunchtime, the second part in the evening.
Reason or Justification for Change
Improve security
Impact and Risk Analysis
The changes are small and the risk of the release is low. A reboot of the screens is required. This is why the release is planned to take place in the evening.
Posted Nov 21, 2025 - 16:46 GMT
This scheduled maintenance affected: DCIS Modules (Control Tower).