Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 03, 2025 - 12:00 GMT
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 28, 2025 - 12:36 GMT
Scheduled
Full Details of the Required Change
This release provides the Edge ScreenApp with the capability to report more granularly on their different health statuses, in addition to the binary online/offline status. These health statuses can be shown on a new feature, the Service Performance Dashboard, which will be made available to you soon. The aim of the dashboard is to increase visibility of live and period-to-date system performance data, details about servicedesk tickets, and provide period reports. More details about the roll out of the dashboard will follow at a later moment.
Reason or Justification for Change
Increase visibility of system performance with the aim to resolve issues quicker.
Impact and Risk Analysis
The release will be done in a number of phases. This release note covers the first phase.
At lunchtime the backend for this functionality will be release. The impact of this release is small and risk low. No interruption to the functioning of screens is expected. The release can be rolled back if needed.
In the evening, the linked Edge ScreenApp will be released to 10 screens, which will be a mix of NTIs (platform edge screens) and SODs (Departure screens). The impact of this release is small and risk low. As part of the release the screens will be rebooted, which in this case is expected to take up to a minute. To reduce customer impact the reboot will be done around 10pm. The release can be rolled back if needed. This would require another reboot of the screens.
Posted Nov 28, 2025 - 12:07 GMT
This scheduled maintenance affected: DCIS Modules (Screens).